How can i download viewpoint pdk api?

Viewpoint
Enthusiast

How can i download viewpoint pdk api?

Trying to get the correct path, so that i can dowload viewpoint api. Please help me with it.

7 REPLIES
Teradata Employee

Re: How can i download viewpoint pdk api?

Not sure what you mean as there isn't a "viewpoint pdk api" offering. We once offered a portlet development kit that offered apis for creation of portlets but we have discontinued that offering. What in particular are you trying to do? 

Re: How can i download viewpoint pdk api?

I have requirement to create a Viewpoint portlet to interface with our homegrown data mover tool. But i see that the Viewpoint PDK is not available for download anywhere. Or is it moved to some other location? What options do i have.

Teradata Employee

Re: How can i download viewpoint pdk api?

Sorry to say that we discontinued the PDK for custom portlet development for multiple reasons so that is no longer an option for you.

Enthusiast

Re: How can i download viewpoint pdk api?

Hi Gary,

how to get out of Viewpoint interface a list of roles , a list of roles and users links or a list of roles and permissions, all that sort of documentation for helping not to run through portlets and  tabs to gather pieces of information ?

User management list  has an "export" button, roles management screen has no equivalent option.

 Thanks,

Pierre

Re: How can i download viewpoint pdk api?

Hello Everyone.

I was wondering if i could now download the PDK or someone else could send me the installers by email.

I have a teradata version 14.0 running on a VMWare virtual machine.

Thank You.

Regards.

Teradata Employee

Re: How can i download viewpoint pdk api?

Pierre,

You are correct, we don't have an export currently for Roles information. It is a roadmap item however.

Gary

Teradata Employee

Re: How can i download viewpoint pdk api?

Regarding the request for the PDK, see postings above. We have formally discontinued distribution of the PDK. Even if you got access to older versions, they would not work with the new versions of Viewpoint.