New Portlet Project fails ant deploy (Host not found?)

Viewpoint
Enthusiast

New Portlet Project fails ant deploy (Host not found?)

Hi all,

I just set up the Viewpoint PDK 13.0.0.1 on a Linux box. Went through all the steps and got things working (mostly), much to my chagrin...

However I ran into issues when trying to follow the 'Generating the Hello Project' sample. Namely, I encountered issues with the ant deploy.

It seems the build.xml makes references to a web location that no longer exists.

Did anyone else encounter this? And, if so... how did you resolve it?

Thanks,

-Peter

sandman Hello # ant deploy
Buildfile: build.xml
[get] Getting: http://continuum.td.teradata.com/svn/NextGen/BuildConfig/trunk/bootstrap.build.xml
[get] To: /Hello/.bootstrap.build.xml
[get] Error getting http://continuum.td.teradata.com/svn/NextGen/BuildConfig/trunk/bootstrap.build.xml to /Hello/.bootstrap.build.xml
init:
[mkdir] Created dir: /Hello/.buildconfig
[get] Getting: http://continuum.td.teradata.com/ivyrep-sandbox/teradata/build-config/3.0-SNAPSHOT/build-config.zip
[get] To: /Hello/.buildconfig/build-config.zip
[get] Error getting http://continuum.td.teradata.com/ivyrep-sandbox/teradata/build-config/3.0-SNAPSHOT/build-config.zip to /Hello/.buildconfig/build-config.zip
BUILD FAILED
/Hello/build.xml:12: The following error occurred while executing this line:
/Hello/.bootstrap.build.xml:21: java.net.UnknownHostException: continuum.td.teradata.com
Total time: 0 seconds
4 REPLIES
Teradata Employee

Re: New Portlet Project fails ant deploy (Host not found?)

Hi Peter...

We're looking into it, stay tuned.
Teradata Employee

Re: New Portlet Project fails ant deploy (Host not found?)

There's a bug in the PDK that prevents redeployment of the sample portlets shipped with the PDK. The workaround for this is as follows:

Generate a new portlet using the PortletGenerator. Then copy the following files/directories from the newly generated portlet into the portlet you wish to redeploy:

.buildconfig/
lib/
web/WEB-INF/lib/
local.build.properties

You should then be able to redeploy the portlet.
Teradata Employee

Re: New Portlet Project fails ant deploy (Host not found?)

I am having a problem with ant deploy on a new project as well. I am getting this error:

BUILD FAILED
Target `tdbuild-static-analysis.checkstyle-javadoc-reports' does not exist in th
is project. It is used from target `checkstyle-javadoc'.

Total time: 2 seconds

Any suggestions?

Thanks,

Robin
Teradata Employee

Re: New Portlet Project fails ant deploy (Host not found?)

To get around the "[get] Getting: http://continuum.td.teradata.com/svn/NextGen/BuildConfig/trunk/bootstrap.build.xml", edit the file ".bootstrap.build.xml" in your project folder (note that because the filename begins with a period ".", it is invisible by default on most OS's). Then, on lines 14 and 21, add ignoreerrors="true" to the task, e.g.