Backup Archive and Restore (BAR)
All things BAR


I have a table (dev.datatable) with after journal and I am trying to copy the data table and copy the journal table and apply that to the copied data table.   The original data table has the journal table in a different database (jnl.AJTbl). -- both the data table and the journal table have been archived.


When I tried to copy (from archive) the data table as a new table in to the same  database 'dev'  I got an error '3825:Incomplete table' -- not sure what this means -- below is the message details -- as when I ran a check table on the database it could not find any tables with errors.


So I changed to target database to 'dev2' and I got the error that the database does not have a journal table.

So I created a journal table dev2.newajtbl and was able to copy to the 'dev2' database.

-- incidentally the copied table points to the journal table dev2.newajtbl and not to the orignal jnl.AJTbl


In the next step I tried to copy the jnl.AJtbl that was archived and apply to the dev2.DataTable -- again hit with the error -- 8218: Datatable does not use the specified journal table.


When I looked for any documentation for the criteria for copying and applying journal data in Teradata 15.10 documentation there is very little info on this.


Can any one shed some light on what I am doing wrong and what needs to be done?


Thanks and apologize a long post.

3825 Incomplete table.
Explanation: A failed restore probably left a DBC table incomplete. An attempt was made to access the incomplete table
using a secondary index but nothing was found where there was supposed to be something. At the moment, a bad restore
is the only thing known to cause this error.
Generated By: RES modules.
For Whom: End User.
Remedy: Do a good restore .