ODBC driver removal - need help please


ODBC driver removal - need help please

Hello. I am trying to upgrade a user's Teradata from 7.1 to 8.1 but the process stops b/c the (old/original) ODBC driver isn't completely removed. I believe that it has to do with the registry wasn't cleaned up in the removal process.

We have searched all through the LocalKeys and everywhere and cannot find the ODBC driver anywhere, which leads us to the registry...

Some forum users have mentioned that they have seen this happen before, and refer to some documents - but not how to find them, and I cannot find or get to these documents on how to clean up the registry myself, or how to proceed with completely removing the old ODBC.

Can someone please help me? Thanks!!!

Re: ODBC driver removal - need help please


Have you tried to uninstall through Start/Configurations/Control Panel/Add or Remove Programs?
Could you provide the error message that you are receiving back?
I had a similar error in the past, but it happened with Teradata Demo, and I had to use the regedit program to search the registry and remove all the Teradata manually.


Re: ODBC driver removal - need help please

Well, this is a work-installed program, and with the way that this program was installed initially, it has to be uninstalled via a tool that is remoting in (it's in add/remove programs but you can't manually remove it from the computer there).

So we completely removed the program via the tool, but then we get stuck on installing the new driver portion b/c it detects the old ODBC driver.

We did search via regedit and didn't necessarily find any ODBC-related items that were obvious, which made us believe that is tied to the registry files (based on what we were thinking and on what I've read in the forums, 2 posts). However, we don't know what registry files to remove.

What did you instruct the search to look for? I believe we tried that too, but maybe we didn't use the right terms?

Thanks Fabio!

Re: ODBC driver removal - need help please

Ok, here is more background info:

I'm trying to remove version Teradata 7.1 / and trying to install Teradata 8.1 /

(why is the driver number version decreasing?)

Uninstall proceeds fine;
Install of Tools & Utilities is fine;
--> Install of ODBC - here is the conflict - it detects an install of a previous driver and will not proceed

Any thoughts?

Re: ODBC driver removal - need help please

Have you restarted the PC after doing the uninstall?

Why are you installing an older version of the driver?

You should contact you sales rep / TD customer service to ensure that you are installing the correct version of the driver and its dependencies.


Re: ODBC driver removal - need help please

I did restart after the uninstall...

I'm not entirely sure why the driver version is older than the previous one - that's a puzzlement - when the Teradata itself is being upgraded. All of the instructions and the software came from another group within this company who has tested it, but they also have a disclaimer that only the IT dept. can support it and not them (hence me and another tech working on this).

So the install of 7.1 came with the odbc driver (pushed via wire) and the install of 8.1 (which I am manually doing) is packaged with a driver.

(the fact that that doesn't make sense, makes sense in this company that has no sense! lol)

thanks David!


Re: ODBC driver removal - need help please


When I removed my Teradata installation manually, I did a search in registry looking for expressions containing the word "teradata" first, and then I did a new search looking for "tdat". I only was able to reinstall the Teradata Demo after proceeding this clean.
Before, I receive an error message saying that a Teradata installation was present in my computer, and that the installation could not continue. That was driving me crazy, because I already had removed the Teradata Demo installation through the uninstall utility, and supposedly should not have a Teradata installation in my computer.

I hope this helps!

Re: ODBC driver removal - need help please

Is there any way to uninstall a driver in Mac?

I am getting 

Teradata Client 15.00 is installed and needs to be removed before installing Teradata Client 14.10.Teradata Client 15.00 and Teradata Client 14.10 cannot be installed at the same time.