Special Characters in Password


Special Characters in Password


The password for my user id is L4sQ&dS8.

I did the following :

Ran a bteq as .logon prod/subrata_das_admin,L4sQ&dS8;  ---> This worked fine

when  ran a MLOAD as below it failed with error -->  13:55:53 UTY1008 RDBMS failure: 8017, The UserId, Password or Account is invalid.   


logtable subrata_das_admin.inslogtable;

.logon prod/subrata_das_admin,L4sQ&dS8;

.begin import mload tables subrata_das_admin.employee

 sessions 20;


I am able to connect to SQLA/winddi/bteq through the same password but it is failing in the MLOAD program. If I use $ as special characters it works (e.g. L4sQ$dS8) 


1) Is there any restriction on using special characters like &, @ etc in passwords ? if so what are the valid special characters ?

2) Is there any other issue ?


Subrata Das


Re: Special Characters in Password


I have encountered this recently. Not sure about one slingshot answer, but, try doing the following:-

1. Enclose the password in double-quotes. It worked in Arcmain, not in BTEQ.

2. for special characters @ and /, use \ as escape character. It worked in BTEQ, not in ARCMAIN.

3. Check what special characters are allowed in the "Special" section in Teradata Admin tool .

                       TDAdmin, Tools->Administer-> Profiles ->"Password" tab. Do not tweak with it until you get an approval from your team.

If anybody finds any other alternatives, please post them.