Teradata XML services - help needed


Teradata XML services - help needed

I have installed Teradata XML services into our test environment. During the installation I needed to modify the scripts to increase the spoolspace max for the SYSXML logon to 2GB to get the libraries to load properly - that was a bit painful. Now, I am trying to work through the first example in the document - generate a canonical schema from an existing table/view. Here's the command that I am using:

call sysxml.gen_query_canonical_schema('select * from ttmp.rs_xml_test','logon','pass', outv);

I am running this through TSA. It just sits there and runs with the hourglass - over 20+, 30+ minutes before I kill it. Seems like something is not right. Any comments or advise on this problem?

Re: Teradata XML services - help needed

Here's an update: I ran the same command through a BTEQWIN session and was able to get/export the results. The command ran very fast. Obviously, there is some incompatibilty issue with my TSA configuration that cannot successfully receive the results from the procedure. If anyone has any ideas about this, I'd like to read them.

Re: Teradata XML services - help needed

Another update: If I select "export results" in TSA, then the command seems to quickly run to completion (as expected) and successfully return 1 row of results. However, I do not get the results in the export file. I'm not sure where the results are going? Has anybody successfully returned LOB results to a TSA session?

Re: Teradata XML services - help needed

FYI - Here's the final update to this thread. I needed to install/use the version 12 (TTU 12) software for ODBC and TSA. Now, stored procedure LOB results are correctly returned to the Windows client through TSA.
Teradata Employee

Re: Teradata XML services - help needed

I have downloaded and Teradata 13.10 VM version and trying to install xml services. Half way through, I am getting the following message.

Install stub UDFs failed. Please check TeradataXML_LINUX_v13.10.00.01/log/createStub.log> for details.

I have notices messages like these and am guessing some .so files are missing.

 *** Create function completed with error(s).

 *** Warning: 5603 Errors encountered in compiling UDF/XSP/UDM/UDT/JAR.

 *** Total elapsed time was 1 second.

Errors/Warnings reported during compilation


/usr/bin/gcc -D_REENTRANT -D_LIBC_REENTRANT    -I/usr/tdbms/etc   -L/usr/td

bms/lib  -fpic -c Teradata_new_delete.cpp

/usr/bin/gcc -D_REENTRANT -D_LIBC_REENTRANT    -I/usr/tdbms/etc   -L/usr/td

bms/lib   -fpic -c  pre_stub_xerces.c

/usr/bin/gcc -shared -fpic -Xlinker -rpath -Xlinker /usr/tdbms/lib -Wl,--ve


ions.scr -D_REENTRANT -D_LIBC_REENTRANT    -I/usr/tdbms/etc   -L/usr/tdbms/

lib  -o libudf_0409_2.so  Teradata_new_delete.o pre_stub_xerces.o    /home/

tdatuser/xml/TeradataXML.  -ludf  -lm -ljil -lstd


gcc: /home/tdatuser/xml/TeradataXML. No such fil

e or directory

make: *** [libudf_0409_2.so] Error 1

/var/opt/teradata/tdtemp/UDFTemp/0409.16383.2c4fe/libudf_0409_2.so: cannot

open shared object file: No such file or directory


/var/opt/teradata/tdtemp/UDFTemp/0409.16383.2c4fe/libudf_0409_2.so: cannot open shared object file: No such file or directory

The folder path till UDFTemp is valid and I have nothing inside this folder. Not sure how to fix this.

Any help is greatly appreciated


Teradata Employee

Re: Teradata XML services - help needed

I am also running into the exact same problem as above, however target system is 13.10 Linux (not VM)

Not applicable

Re: Teradata XML services - help needed

Teradata XMLELEMENT and XMLATRRIBUTE functions:

Can anyone pls give me the exact syntax of function SYSXML.XMLELEMENT and SYSXML.XMLATTRIBUTE in Teradata in detail?

Teradata Employee

Re: Teradata XML services - help needed

Managed to get this to work with the help of the developers.

First had to drop the SYSXML user from the DB, then removed the /home/tdatuser/xml directory from every Linux node for the DB system.

Ran the install again and it worked. I think a previous install attempt which had failed (possibly using the wrong install package) may have resulted in the failures I was getting.

Re: Teradata XML services - help needed

After a good struggle for several hrs below are the step I used to sucessfully install Teradata XML

Bhanu --> Below step will resolve your issue and if your UDF are corrupted and not able to delete or drop from database, login with betq as super user and run below 2 command



This will drop and clear all corrupted UDF ( as I struggled to drop them when binaries got corrupted)

  1. Download the packages from Teradata Developer exchange based on your system (Linux,MP-RAS,Windows)
  2. Download Perl packages from (www.activestate.com/activeperl/downlaod) community free edition 
  3. Unzip all the file downloaded from developer exchange on your local driver
  4. Logon to your Teradata Server/Node  and create 2 directories under home/tdatuser (XML and TeradataXML13.00.00.00 make sure to create on each node +HSN) as UDF package dose not create it automatically ( do not run any UDF install from Node)

home/tdatuser # mkdir xml

:/home/tdatuser # chmod 777 xml

:/home/tdatuser # cd xml

:/home/tdatuser/xml # mkdir TeradataXML.

:/home/tdatuser/xml # chmod 777 TeradataXML.

:/home/tdatuser/xml # cd TeradataXML.

5) Once XML and TeradataXML folder created on the nodes go back to your C:/D drive where you have downloaded the package and go to directory lib and copy 4 files (.so) to /home/tdauser/TeradataXML13.00.00.00 directory

(These file does not get copied/created by UDF and it will give you error while compilations of UDF)


  1. libxalan-c.so
  2. libxalanMsg.so
  3. libxerces-c.so
  4. libxmludfs.so

Change permission on the (4) file to 777 on all the nodes

  1. Once above 5 steps done, go back to your desktop/machine where the packages you have extracted and go to bin directory and run command --> perl  installudfs.pl
  2. Check the log file and report .html file for any errors

hope this help enjoy