cant connect to teradata demo cd 8.1 with JDBC


cant connect to teradata demo cd 8.1 with JDBC


big problem - hoping easy solution:

I hv installed the teradata demo 8.1 (windows 2003) and if I use bteq to connect
to database DemoTDat using account dbc/dbc and selecting tables it works fine.

If I try to start the sample application "Complex Query" then I get
10054 WSA E ConnReset: Connection reset by peer.

Now we want to use JDBC (Level4) to do the same.
We hv tried teradata JDBC driver and and with
both drivers we get the same error message:

2004-05-18.22:33:55.093 TERAJDBC4 ERROR [Thread-8] com.ncr.teradata.jdbc_4.TDSession@199de59 Read message 1 failed; closing socket due to: Connection reset

2004-05-18.22:33:55.437 TERAJDBC4 ERROR [Thread-8] com.ncr.teradata.jdbc_4.TDSession@199de59 Packet stream read error: local= remote=/ cid=3f0bc0 sess=1015 Tue May 18 22:33:55 CEST 2004 Connection reset at Source) at at at at com.ncr.teradata.jdbc_4.statemachine.StatementReceiveState.action( at com.ncr.teradata.jdbc_4.statemachine.StatementController.runBody( at at com.ncr.teradata.jdbc_4.Statement.executeSessionCommand( at com.ncr.teradata.jdbc_4.TDSession.( at com.ncr.teradata.jdbc_3.ifjdbc_4.TeraLocalConnection.( at com.ncr.teradata.jdbc.ConnectionFactory.createConnection( at com.ncr.teradata.TeraDriver.connect( at java.sql.DriverManager.getConnection(Unknown Source) at java.sql.DriverManager.getConnection(Unknown Source) at com.onseven.dbvis.wrapper.DriverManagerImpl.getConnection(Unknown Source) at com.onseven.dbvis.sql.M.?(Unknown Source) at com.onseven.dbvis.sql.M.access$200(Unknown Source) at com.onseven.dbvis.sql.M$A.execute(Unknown Source) at se.pureit.util.ThreadCommand.runExecute( at at Source)

After this try the demo database is down/stopped!

We use:
and dbc/dbc

With the former teradata demo version it has worked fine ....



Rainer Kopp