Connecting VMware to Teradata Studio


Re: Connecting VMware to Teradata Studio

Thanks dnoeth,

Have a look at my snapshot as i have an error running the create User statement.

I'm connected using the dbc schema to run this statement.

I then tried to add the new connection properties and got an 'unknown user, password error.

Where am I going wrong?

Btw, changed between the 20+e9 and the 2000000000 to see if it was an error, but neither will work.

Thanks Peter



Re: Connecting VMware to Teradata Studio

The parser complains about the password, which must follow the rules for object names (a-z,0-9,_,#,$) by default. If you want a password with other characters you must double quote it: "********"


But I assume you run that command before and as it contains a password it was automatically masked in the history and you must key it in again to run it a 2nd time).


Re: Connecting VMware to Teradata Studio

I think I need to get past the Create User step first.

I'm loggged in as dbc/dbc using the inet address I found using the ifconfig cmd prompt.

While logged in as dbc, I ran the query that you gave me "Create User oscar ..."

I get an error about "The request to assign permanent space is invalid".

Also, when you say Logout, do you mean restart? 

I can't find a logout option.

Thanks P  

Teradata Employee

Re: Connecting VMware to Teradata Studio

20GB may be larger than the remaining PermSpace. Try a smaller allocation.

"Logout" is labeled "Disconnect" in Teradata Studio client. (Right-click the connection in Data Source Explorer.) Or just close / re-open Studio.


If you decide that you want to run Teradata Studio on the host desktop instead of within the VM, review other posts in the Tools forum and start a new thread there if necessary. In particular, you may want to use 16.20.08 (which requires Java 8) instead of 16.20.09 (which requires Java 10).