Installed but could not use it


Installed but could not use it

Hello All,

I'm new to Teradata but have been working on other RDBMSs (oracle, SQLserver, & MS Access) for several years. I installed Terdata Express Edition 12.0 recently on personal Desktop system Windows XP. Then, I configured it to the best of my understanding as described on one of the documents I found on the web (TeradataClinet4.pdf) below is what I did:

1. Modified hosts file
2. setup environment variables
3. modified Clispb file

Using BTEQ I tried to view the tables. Although I did not create user, I used the username and password the document shows: " .logon teradata/john" password "johnpass" hoping it knows that user by default. The result I received is not good.

" **** Warning DBS crushed or Session Reset - Recovery in progress>"

with this error message it sits there forever.

I tried to see if I can find a tutorial book or document that can help me learn as a beginer and could not find one.

Finally, I decided to turn to asking you men and women of the Teradata experts to help me get Teradata up and running. Please respond me with instructions and/or locating a book I can refer to or even a number I can call and have someone assist me on this. I'm wasting a lot of hours and could not move an inch from where I was when I first installed which is a week or so ago.

Thank you in advance for your assistance


Re: Installed but could not use it

You may be running into the infamous Windows DEP feature. Look in the Windows Event Log to see if a memory access exception was logged. Check out this URL for a detailed explanation of DEP:

In order to run Teradata, you will need to disable this feature.

Edit c:\boot.ini, look for "/noexecute=" and change the parameter value after "=" to "alwaysoff". The file should like something like this:

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=alwaysoff /fastdetect

Re: Installed but could not use it


Thank you much for your prompt response on this matter. I searched for the file (boot.ini) and could not find it on my PC. Is this file comes to XP during Teradata installation or it should be there? Is it a file I can create with the text/verbage you posted?

Thanks again


Re: Installed but could not use it

Boot.ini is a hidden file used by windows during startup. You probably don't have to care about it, i suspect you just didn't start Teradata :-)

What do you mean by "I configured it"? The Express version is already configured, you just start using it.
And if you try to configure it better don't use a fishy PDF found on the internet based on V2R5 several yeras ago.

Did you read the provided help file (tdexpress.chm)?
Did you check /Docs/Getting_Started/Getting_Started.htm?


Re: Installed but could not use it

I did change back to its original setting. In other words, I did undo the steps I described in my previous posting. This time, I tried username I see in the ODBC config object. What I mean by that is when I open the ODBC it showed me a dialog box where its connection and other properties are entered. ( I did not enter it manually. I assume that all was take'n care of when I installed TD) Since the password box is encrypted in there. I used the username itself--username=tduser and password=tduser. And below is the error I got.

Teradata BTEQ for WIN32.
Copyright 1984-2007, NCR Corporation. ALL RIGHTS RESERVED.
Enter your logon or BTEQ command:
.logon tduser
*** CLI error: MTDP: EM_NOHOST(224): name not in HOSTS file or names database.

*** Return code from CLI is: 224
*** Error: Logon failed!

*** Total elapsed time was 3 minutes and 41 seconds.

Teradata BTEQ for WIN32. Enter your logon or BTEQ command:
I also tried to locate the getting started doc you mentioned above. but I could not find it in Terdata's website. Could you please send me the URL for that /doc/getting started document ? My other question is how do I find what username and pw to use to login? Or how do I connect to the database?

Your assistance is greatly appericiated.



Re: Installed but could not use it

Hi Al,
that document is on the Express DVD, i don't have access to that right now, but you'll find usernames & passwords in it.
And i think you'll find it in Start - Programs - Teradata demo, too.
There's also the Service Control Program, run it to see if Teradata already started, if not, start it.
Then use SQL Assistant or Teradata Administrator to connect using ODBC.

For BTEQ/CLI you need to check the doce or the hosts file for the Teradat name used, but you might also use .logon to logon.


Re: Installed but could not use it

Hi Dnoeth,

I did check out the Getting started document but still unable to login and see the data in the Teradata database. The doc shows usernames (tdadmin & tduser). I tried using the two utilities-- it indicates the SQL Assistant 12.0 & Terdata Administartor 12.0 they both could not get me there. I know it is my fault not TD's but what can you do that the only way to learn :-)

when trying using the Teradata Administrator it comes with this:
"ODBC-HY00: Major Status=0x04bd Minor Status-0xe000000f-Success/Continue needed " message in the bottom sits for ever.

when trying via the SQL Assistant, it prompts me to connect using ODBC and I choose tduser and it shows the following error

ODBC-HY00: Major Status=0x04bd Minor Status-0xe000000f-Success/Continue needed
ODBC-HY00: Major Status=0x04bd Minor Status-0xe000000f-Could not locate the tdgss library
ODBC-HY00: cannot find terasso library
ODBC 28000: Not enough information to log on

I still screeeeeeeeeeeeeeeeeeeeeeeeeeemm for help :-)

Thank so much


Re: Installed but could not use it


Try userid/passwd :dbc/dbc

Re: Installed but could not use it

Hi Al,
you probably skrewed up your installation, TDGSS is not installed correctly.

I'd suggest to uninstall the Teradata demo completely (maybe even check the registry for remaining entries and remove them) and re-install it.