Replacing Macros Problem


Replacing Macros Problem


I am trying to replace or rather create a set of macros in my dev env but facing an error
3932:Only an ET or null statement is legal after DDL statement.

For example :

Replace macro mac_1( );
Replace macro mac_2( );
and so on ....

I have tried this before and it had worked fine.Not sure why its not working now.

Is there any setting that needs to be changed ?

Thanks a lot for your reply.


Re: Replacing Macros Problem

Hi Friends,

Any body can help me on this ??

Thanks a lot for your quick answers.


Re: Replacing Macros Problem

Check the obvious first:
1. Make sure you are not running in ANSI mode. (Select * From DBC.Sessioninfo Where Username = User - The TransactionMode should be set to 'T')
2. If you are running in Bteq, make sure there is no "Begin Transaction" before the Replace strings.
3. If you are running in SQL Assistant, make sure you use the Execute, not the Execute Parallel (the single pair of feet, not the army squad!)

After this, check your SQL assistant and Teradata levels. I had a similar problem on V2R6, but I dont get it on Teradata 12/ SQL Assistant 12.

If all else fails, wrap a BT/ ET around each Replace Macro!