otranslate - strange behaviour


otranslate - strange behaviour

We'we got a strange problem. We use otranslate function to detect non-number characters in a column like this:

otranslate(text_column,'a1234567890','a') and then convert to decimal(if number of chars is 0) - and it works fine.

But yestarday our ETL process failed during cast as decimal and I found that problem was with one record which contains text_column='018C87' and otranslate istead of 'C' returned empty string so number of chars was 0 but cast as decimal failed (becauce of C letter in a string).

I tried to find out why otranslate does't work properly and then I discovered that something is strange. I Change just for test to otranslate(text_column,'1234567890','q') and as the result I  got 'q' !, but when I changed this back to otranslate(text_column,'1234567890','a') i still

got a 'q' !, I tried log off, and log on even from different clients but always got 'q' as a result. I could change whatever in second and third parameter of otranslate and I always got 'q' in the result!

The most strange thing is, that when I run this piece of code today it works properly! otranslate(text_column,'a1234567890','a') returns 'C'

Do you have any Idea what was that ? some cache or something like this ?

Thanks for help