New laptop+version upgrade and my history .mdb was not imported.


New laptop+version upgrade and my history .mdb was not imported.

Just yesterday I had my old laptop refreshed with a newer one by my company as part of the move to Windows 7.  Included in that migration was updating to Queryman (SQL Assistant) v13.   This led to my history database from v12 not being picked up during the installation of v13 even though it was in what I believe is the default folder “My Documents/NCR/Queryman”. 

[u]Here’s what I’ve tried so far:[/u]

  • Using copies of the originals I’ve tried opening the v13 .mdb file and importing the v12 QHIST table into it, then using an append query to move the fields from the v12 table to their v13 counterpart.  The problem there is that only the Date/Time, Source and Rows fields are displayed in the History pane when I open Queryman.  The data is clearly there if I open the .mdb file and look at the History table but for whatever reason it’s not being pulled into the History pane within the Queryman application.
  • Next I tried exporting the v12 QHIST table to a .txt file and importing that into the v13 History table.  The results were even worse.  Even after choosing the pipe “|” as my delimiter when I opened the .txt file it looked like Notepad was treating both the pipe and comma as a delimiter.
  • I’ve tried various keyword combinations in Google and haven’t been able to find any mention of a similar issue and looking at the links that looked even remotely related yielded no results.
  • My final idea was to convince our PC Tech Support staff to upgrade my old laptop to v13 and see if the History is properly pulled in there and if it is then I plan to copy it over to my new laptop; though I’m not holding much hope that this will work either.

Note that new queries file the .mdb table and History pane with complete information and look normal.  I’m looking for any other ideas at this point because this history is pretty important.


Tags (3)

Re: New laptop+version upgrade and my history .mdb was not imported.

This has been solved by:

  1. upgrading the Teradata client to v13 on my decommissioned laptop
  2. opening Queryman on that device and letting it convert the history .mdb file on first load.
  3. Once that was complete I verified the history was properly displayed in the History pane and closed Queryman
  4. Then I copied the history .mdb file to a thumb drive and moved that copy into the history path on the new laptop. 

Upon opening Queryman on the new laptop my history data was available in the History pane as it should be.