Failed to pre-validate CPU number

Teradata Database on VMWare

Failed to pre-validate CPU number

When deploying teradata dev 15 i'm recieving the following error

"Failed to pre-validate CPU number, desired CPU number ( 4 ) exceeds the maximum available CPU number ( 1)."

If I modify the file and specify "cpu" to 1, it then says the same error, but "desired CPU number (2) exceeds" . It seems there is something that it multiplies the desired cpu , maybe due to hyperthreading or something else.


Oddly, I have plenty of cpu resources available on the specified esxi host.  I'm tried other hosts as well with the same issue.  Is there a way to force or not require this check?


Is there a way to just launch the .ova template, then configure the database setup after? the scripts seem to be one issue to work through after another.

Thanks for any help!

Teradata Employee

Re: Failed to pre-validate CPU number

If you are having lots of issues with the scripts, double check that your environment meets the requirements - particularly Powershell and PowerCLI versions.
Teradata Employee

Re: Failed to pre-validate CPU number

Make sure that you have not overprovisioned your CPUs on your VMWARE server. Make sure you are deploying to a Vcenter and not an ESXi host directly.  As mentioned make sure your PowerCLi and Powershell meet the versions mentioned in the manual. Also if you can share which version you are deploying (Enterprise Tier, Advanced Tier, Developer Tier Paid, Developer Tier Free, Community Edition) and the version number (I.E TVME 15.02, TVME 02.01.05, etc...) . If you you can attach a screen shot from VCenter showing how may CPUs are used and how many are available. Also if you can post your property files  and deployment log that would also be helpful. The deployment log should be in a log subdirectory under where you run tdc.deploy.ps1 from.


In the  example below I show that my  Esxi host (dbs-tvme4)  has 8 CPUs cores which provides 16 logical CPUs. Then I have to subtract the logical CPUs of each image that is running on this host.  In my example I just have a Vcenter running on this host so I subtract 2 logical CPUs leaving me with 14 logical CPUs available for other VMS. For your Teradata images the minimum is 1 physical cpu core which means 2 logical cpus. So in my example I really have 14 logical CPUs available. Find your total number of logical CPUs and subtract the CPUs that each vm image running on that host is using and see how many you have left. Most VM systems are overprovisioned meaning that you are running more logical CPUs than the system actually has available. Teradata requires that you have reserved CPUs in order to deploy.






Re: Failed to pre-validate CPU number

Thanks a ton - that first issue was resolved by making sure the host was not over provisioned cpu.  I am deploying developer free edition for testing.

Looks like i need to work out the vswitch configuration, as that is holding it up now.

Re: Failed to pre-validate CPU number

I was able to successfully deploy the VP server, but having issues with the DB server now.   I've changed the node properties to just include the tpa. but still getting the following issue.  Datastore has plenty of free space - but can storage be overcommited?

6/2/2017 10:39:24 AM  - Deployment of  Teradata15  started...

TaskID          State        PercentComplete   StartTime              Type                    VM Name
Task-task-1341423 Running      0                 6/2/2017 10:39:24 AM   Deploy OVF template  Teradata15
Successful( 0 )
VM ( Teradata15 ) Cloning Failed

TaskID          State        PercentComplete   StartTime              Type                    VM Name
Task-task-1341423 Error        100               6/2/2017 10:39:24 AM   Deploy OVF template  Teradata15
Successful( 0 )
 Failed( 1 )
6/2/2017 10:42:23 AM -   ( 1) Failed to clone and (0) succeeded, exiting!
Teradata Employee

Re: Failed to pre-validate CPU number

Usually if there is not enough space the pre-validation portion of the deployment scripts will explicitly tell you that. Can you provide the deployment log which is located in the Logs subdirectory under where you are running tdc.deploy.ps1? Also if you can provide the two property fies that might be helpful.


Also, did you pre-upload the ova file by picking "Deploy OVF Template" and then after it uploads pick "Convert to Template" or did you have your deployment script do the file tranfer? I highly recomment that you first upload the file to the ESXi host you will be deploying it on because it speeds up the deployment and makes it easier to re-run each deployment when you run into deployment issues.


From KCS KCS004636


How to upload an ova template and deploy it as an ovf template on VMWare


   Product Categories  Link Count -0  
    Teradata Virtual Machine    
The purpose of uploading the Teradata on VMware ova file to the server and converting it to an ovf file is to speed up the deployment of Teradata on VMware and to make subsequent deployment attempts much faster by skipping the upload step.
The procedure below is how to upload the ova template file for deploying Teradata on VMware and converting it to an ovf template file. This will make your initial deployment of Teradata on VMware and subsequent deployments run much faster.
  1. Click on Hosts and clusters on the left pane
  2. Click on your Data Center and expand it ("DBS Data Center" in the picture )
  3. Click  on your server name ("" in the picture below)  and expand it
  4. Then click on Actions >> Deploy OVF Template (you can also right click on the server name to get to the same place)



5. Next you should see a pop up window where you can click "browse" on your PC to find the OVA file that you wish to upload.

6. Browse to the ova template file, highlight the file to upload then click "open".

7. After uploading your file right click the file "Template" >> "Convert to Template"




Re: Failed to pre-validate CPU number

good tip, that will help in the future.  This is solved now, I redownloaded the ova, seems there was some issue with it.  I'm deployed and ready to go.

Thanks again for all the help

Teradata Employee

Re: Failed to pre-validate CPU number

Glad you got it working!