Teradata Developer 16.20 - preconfigured OVA - root password error

Teradata Database on VMWare
Enthusiast

Teradata Developer 16.20 - preconfigured OVA - root password error

Hi, just tried to deploy the 16.20 preconfigured ova and at the end of the tdvm-it (ran with root/iumb123) got the error:

 

Error: TD Put Process has ended prematurely. This was most likely caused by an invalid root password. Please enter the correct password and try again. 

Error: Sysinit or Database initialization Program did not start properly.

 

If I rerun tdvm-init I get:

********************************************************************************
** Begin configuring Teradata Simplified Developer Tier Edition.
********************************************************************************
Info: There is an already existing Teradata configuration on this system. Exiting.

 

If I run /etc/init.d/tpa start I get:

 

linux:/var/log # /etc/init.d/tpa start
Teradata Database Initiator service is starting...
Teradata Database Initiator service failed with 4 exit code

 

And the /var/log/messages show

 

Apr 6 19:16:56 linux kernel: scsi 0:0:1:0: Direct-Access VMware Virtual disk 1.0 PQ: 0 ANSI: 2
Apr 6 19:16:56 linux kernel: scsi 0:0:1:0: mptscsih: ioc0: qdepth=32, tagged=1, simple=1, ordered=0, scsi_level=3, cmd_que=1
Apr 6 19:16:56 linux kernel: sdev dma_alignment 511
Apr 6 19:16:56 linux kernel: scsi target0:0:1: Beginning Domain Validation
Apr 6 19:16:56 linux kernel: scsi target0:0:1: Domain Validation skipping write tests
Apr 6 19:16:56 linux kernel: scsi target0:0:1: Ending Domain Validation
Apr 6 19:16:56 linux kernel: scsi target0:0:1: FAST-40 WIDE SCSI 80.0 MB/s ST (25 ns, offset 127)
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: Attached scsi generic sg1 type 0
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] 392167424 512-byte logical blocks: (200 GB/187 GiB)
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Write Protect is off
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Mode Sense: 61 00 00 00
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Cache data unavailable
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Assuming drive cache: write through
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Cache data unavailable
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Assuming drive cache: write through
Apr 6 19:16:56 linux kernel: sdb: unknown partition table
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Cache data unavailable
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Assuming drive cache: write through
Apr 6 19:16:56 linux kernel: sd 0:0:1:0: [sdb] Attached SCSI disk
Apr 6 19:17:06 linux vconfig[5677]: WARNING: TdatTools: 29002 #The vconfig GDO file does not exists in the path </etc/opt/teradata/tdconfig/vconfig.gdo>.
Apr 6 19:17:06 linux kernel: tdmeter: IopsScaler Set To 10%.
Apr 6 19:17:06 linux kernel: tdmeter: IopsScalerSSD Set To 10%.
Apr 6 19:17:15 linux kernel: kjournald starting. Commit interval 15 seconds
Apr 6 19:17:15 linux kernel: EXT3-fs (sdb2): using internal journal
Apr 6 19:17:15 linux kernel: EXT3-fs (sdb2): mounted filesystem with ordered data mode
Apr 6 19:17:23 linux vconfig[6166]: WARNING: TdatTools: 29002 #The vconfig GDO file does not exists in the path </etc/opt/teradata/tdconfig/vconfig.gdo>.
Apr 6 19:17:23 linux kernel: tdmeter: IopsScaler Set To 10%.
Apr 6 19:17:23 linux kernel: tdmeter: IopsScalerSSD Set To 10%.
Apr 6 19:20:11 linux kernel: kjournald starting. Commit interval 15 seconds
Apr 6 19:20:11 linux kernel: EXT3-fs (sda3): using internal journal
Apr 6 19:20:11 linux kernel: EXT3-fs (sda3): mounted filesystem with ordered data mode

 

I have attached two pdisks of 100 GB successfully (that showed correctly at the end of the ova deploy). It seems the vconfig.gdo is not generated.

 

Anybody got a clue?

 

Thanks


Accepted Solutions
Enthusiast

SOLVED - Re: Teradata Developer 16.20 - preconfigured OVA - root password error

Update - apparently before the init a different root password was entered, once the ova was redeployed with root / iumb123 all along the process it was OK. 

1 ACCEPTED SOLUTION
2 REPLIES 2
Enthusiast

SOLVED - Re: Teradata Developer 16.20 - preconfigured OVA - root password error

Update - apparently before the init a different root password was entered, once the ova was redeployed with root / iumb123 all along the process it was OK. 

Enthusiast

Re: SOLVED - Re: Teradata Developer 16.20 - preconfigured OVA - root password error

I have the correct password for root, but encountered the auth error

 

linux portmgmt: pam_unix2(tdput:auth): Unknown option: 'shadow'

 After got rid of 'shadow' in /etc/pam.d/tdput, 

/opt/teradata/bin/autoput -l root -w iumb123 -q SUPPORT0001 -o 'Configure Teradata'


5554 INFO: Initializing process for '/usr/pde/bin/recond -S'. (ProcessManagerUnix.cpp+238) 5554 INFO: the command line is /usr/pde/bin/recond -S (ProcessManagerUnix.cpp+261) *FATAL* startpde(): can't find pdemain