Fortran needed on Teradata Express 14.10 VM (SLES11-SP1)

Teradata Express Software
Formerly this board name was Cloud Computing. The name was changed to better represent the product areas covered.
Teradata Employee

Fortran needed on Teradata Express 14.10 VM (SLES11-SP1)

Downloaded the image "TDExpress14.10.00.02_Sles11_40GB.7z" (TEVM) and ran it under VMware fine; well done for the good work.

In my project, a package needs to compile Fortran code, so I need a fortran compiler. To this end, the fortran compiler gfortran is available as part of the GNU gcc through a gcc-fortran RPM component. Alas, I noticed that the gcc43 package that was preinstalled in the TEVM image lacks the gfortran component gcc43-fortran. To install the related gfortran RPM, the dependencies demand that the Teradata-related packages are removed first. This is not a viable solution, unless anyone might know how I could get a hold of the bynet, ssde, and the several more Teradata RPM packages that are in conflict, so that I remove them temporarily, install fortran, and reinstall them.

Alternatively, I tried to install a different gfortran package by installing a later gcc version; e.g., gcc47 and gcc47-fortran. However due to the Teradata dependencies, I could not remove gcc43 nor shift usage to the gcc47 compiler. Consequently, the gcc47 components (and gfortran) were not visible to the system and I dropped this option, too.

Any ideas or suggestions will be appreciated.



Teradata Employee

Re: Fortran needed on Teradata Express 14.10 VM (SLES11-SP1)

Update to using Fortran in the specified virtual machine:

Went to the G95 project at webpage, got and installed G95 successfully; problem solved.