TD Studio won't find JRE

Teradata Studio

TD Studio won't find JRE

Hi, I'm trying to install TD Studio having installed the Azul JDK 10 as recommended.  The installer won't find the JRE no matter what directory I point it at.  Running "java -version" from the Windows command line runs "java.exe"; looking in the directory "C:\Program Files\Zulu\zulu-10\bin" shows "java.exe"; running "where java" from the Windows command line finds "C:\Program Files\Zulu\zulu-10\bin\java.exe".  %JAVA_HOME% is set to "C:\Program Files\Zulu\zulu-10", %PATH% is "C:\Program Files\Zulu\zulu-10\bin;C:\WINDOWS\system32;<rest of path...>"

 

I've run out of ways to tell the installer where Java is!  Anyone got any ideas???

 

Thanks, Jim.

Tags (3)

Accepted Solutions
Teradata Employee

Re: TD Studio won't find JRE

Hi,

Studio 16.20.10.XX will support both 10 and 8 versions.

Let us know which version of Studio you are trying to install?

We will check that once, Meanwhile Please try with Zulu 8. 

 

 

1 ACCEPTED SOLUTION
4 REPLIES 4
Teradata Employee

Re: TD Studio won't find JRE

Make sure you are using version 16.20.10.00 or higher of Studio.

Are you using the setup.exe (not launching the .msi directly)?

Did you have a prior version of Studio installed?

Was some other Java distribution previously installed?

Did you install Zulu using the zip file or the msi?

 

 

 

 

Teradata Employee

Re: TD Studio won't find JRE

Hi,

Studio 16.20.10.XX will support both 10 and 8 versions.

Let us know which version of Studio you are trying to install?

We will check that once, Meanwhile Please try with Zulu 8. 

 

 

Re: TD Studio won't find JRE

Hi Fred,

I'm trying to install 16.20.10.01.

I've tried both setup.exe and the MSI installer with the same results

I have no prior version of TD Studio installed

I had no Java at all previously installed (it's an almost clean Win10 machine)

I installed Zulu using the MSI

 

Regards, Jim.

Re: TD Studio won't find JRE

Hi Srilatha,

The installation worked with Java 8.  Interestingly the "java.exe" file installed for 8 is dated 2019-04-14 and for 10 is dated 2018-03-21 - seems a bit old.  Also on the link on developer.teradata.com for Zulu 8 it takes you to a page with the choice of Java 7, 8, 11 or 12 - nothing for 10.  Perhaps there's an issue with 10?

 

Anyway, all seems to be working now.

 

Thanks and regards, Jim.