Unable to find the requested .Net Framework Data Provider. It may not be installed.

Third Party Software
Teradata Employee

Unable to find the requested .Net Framework Data Provider. It may not be installed.

Hi All,

 

I've been used a VB tools that connects to TD14.00 on Win7 PC and now I tried to do to TD16.20 on Win10, received the following error messages.

[ Unable to find the requested .Net Framework Data Provider. It may not be installed. ]

 

It means that the tool is compatible to .net framework 3.5 , so I have to modify to the following strings for applying the .net framework 4.5 , doesn't it?

 

  <connectionStrings>
    <add name="Teradata" connectionString="User Id=[USERID];Data Source=dbc;Password=[PASS];Session Character Set=KANJISJIS_0S;Max Pool Size=5;Min Pool Size=1" providerName="Teradata.Client.Provider" />
  </connectionStrings>

 

or if not, what should I fix? could you please help.

 

Thanks in advance,

A teradata fan

 


Accepted Solutions
Teradata Employee

Re: Unable to find the requested .Net Framework Data Provider. It may not be installed.

This problem was solved. I re-compiled this module with .Net Framework 4.0.

 

Thank you for your reply, Fred.

 

Regards,

quatre

1 ACCEPTED SOLUTION
3 REPLIES 3
Teradata Employee

Re: Unable to find the requested .Net Framework Data Provider. It may not be installed.

Have you installed the Teradata .Net data provider?  (It's part of the base TTU bundle; also available separately from downloads.teradata.com - see link on htis site - or nuget.)

Highlighted
Teradata Employee

Re: Unable to find the requested .Net Framework Data Provider. It may not be installed.

This problem was solved.

I recopiled the modules with .NET Framework 4.0.

 

Thank you for your replying , Fred.

 

Regards,

quatre

Teradata Employee

Re: Unable to find the requested .Net Framework Data Provider. It may not be installed.

This problem was solved. I re-compiled this module with .Net Framework 4.0.

 

Thank you for your reply, Fred.

 

Regards,

quatre