BTEQ : Wincli32.dll problem

Tools & Utilities
Not applicable

BTEQ : Wincli32.dll problem


I am trying to login to BTEQ utility.
When I try Window based (BTEQ Win) it ask for ch****t? when I select any ch****t it give error that 'This session is invalid. Do you want to close it?'

what should be the char set?

when I try using command based BTEW it gave following error

bteq.exe - Entry point not found
The Procedure entry point OsGetCOPTDGSSVesrion could not be located in the dynamic link library WINCLI32.dll

I tried searching this dll file and there are 4-5 dll file present. 1 is in system32. Others are in teradata folders like 'Porgram File\NCR\Teradata Client\Cliv2','Program Files\NCR\Teradata\WinCLI-Runtime','Program Files\Teradata CLI2 Developer's kit\Devkit'

Thanks in Advance.

Not applicable

Re: BTEQ : Wincli32.dll problem

I had this same ploblem. I discovered the wincli32.dll and tdusr32.dll in the C:\Program Files\NCR\Teradata Client\cliv2 directory was newer than the dlls in the C:\WINDOWS\system32 directory.
BTEQ required the newer version and is looking in the system32 directory. So I copied the wincli32.dll and tdusr.dll from C:\Program Files\NCR\Teradata Client\cliv2 to C:\WINDOWS\system32 directory and replaced the older versions.

This solved my problem. Good Luck!

Re: BTEQ : Wincli32.dll problem

Hi Brian Tausend,
I too faced the same problem last two days.Your solution resolves my problem.Thanks a lot for sharing your valueable knoweledge.

Thanks once again