Decimal error in Mload JCL

Tools & Utilities

Decimal error in Mload JCL

HI Folks,
This Query is about TeraData Mainframe error:
I have Target table for which we are preparing Mload JCL & the Source is Mainframe Flat file.
I have few columns like CHARGES DECIMAL(15,2),YIELD DECIMAL(5,4) ,ROE DECIMAL(7,6)& RESIDUAL DECIMAL(9,9).
I Didnt manipulate it in the Insert phase.
Surprisngly when i look at the data in flatfile using FileAid, column CHARGES is taking only 5 Positions.
When i run the this MLOAD JCL, its running successfully But all rows going to ET Table.the Error reported as 2679.And the description as Below:

2679 The format or data contains a bad character.
Explanation: This error occurs when the user submits a numeric-to-character conversion with an illegal format,
or when, in converting characters to numeric,either the data or the format contains a bad character.

Even i tried to define CHARGES in Layout section as CHAR(15) , Then also getting the same error.
IF you any of faced the problem or anybody knew the solution Please answer me .

Note:FileAid is MF utility through which we can see MF Flat file data in the form of a Table Columns.

Thanks In Advance

Teradata Employee

Re: Decimal error in Mload JCL

Note that .LAYOUT datatypes describe the input file data, not the table column.

It's not clear what you mean when you say the field occupies only 5 positions. Do you mean it looks like x'12 34 56 78 9C', in which case it may be DECIMAL(9,2) not DECIMAL(15,2)?