Fastload Issue

Tools & Utilities

Fastload Issue

It seems every few days, when I decide to use Fastload, I get an error. 

I have had to reinstall it many times to get past this, but once again, it is failing.


C:\Users\afreed>fastload < "C:\users\afreed\documents\fastloadscript_Promos.txt"

**** 12:51:57 FastLoad cannot start. Please check CLIv2 and PIOM dependent libraries


I did a repair of Teradata in the attempt to resolve and now I am getting the error:

**** 12:59:03 CLI Error 527:
**** 12:59:03 Cannot initialize FastLoad. Exiting


Teradata Employee

Re: Fastload Issue

Seems like there must be something else happening on your PC that corrupts the TTU installation. The error 527 is complaining about TDICU instead of CLIv2 or PIOM, but it's a similar symptom.


The odd thing is that the .dll's should be installed in the same directory as the fastload.exe, so if Windows can resolve "fastload" you'd think it would find the libraries also.


Have you tried completely uninstalling all Teradata client utilities, rebooting, and then reinstalling (preferably using a current, supported version)?


Re: Fastload Issue

I have actually uninstalled and reinstalled TD at least two times to get past this issue.  It worked after the remove and install and has popped up again.


I don't tend to reboot every day, so maybe just rebooting will help, so I can try that.  Of course, I can also reinstall and see if that works too, but my gut feeling is that it will happen again.


If it does, is there any other way to get support?



Teradata Employee

Re: Fastload Issue

I think you'd have to ask your Windows support what might be happening to cause this problem. It doesn't seem to be anything to do with the Teradata client software itself.


You might also keep an eye on the contents of C:\Program Files (x86)\Teradata\Client\xx.yy\bin and if something changes, try to figure out what caused it.

Teradata Employee

Re: Fastload Issue

I noticed that your command came from:




Is that a link in that directory to FastLoad?

Or did you install FastLoad in C:\Users\afreed ?

-- SteveF

Re: Fastload Issue

This is not the path I installed it into.  The path does not seem to have anything to so with Fastload working.  Uninstalling and reinstalling works for a few days (not sure as I don't use it everyday) and then starts to fail again.