IMPORT issue with Teradata SQL assistant.

Tools & Utilities

IMPORT issue with Teradata SQL assistant.


Some Background:

I am trying to IMPORT a .csv file using SQL assistant... there are few columns which doesn't have values so ideally it should load NULL values (?) in the table, BUT... its loading ZEROS (incase of numeric fields) instead of NULLs. (incase of char fields its loading SPACE/Blank)

I have tried loading same table with same file on diffrent machine, and it is getting loaded with NULL values as expected!!


1. why SQL assistant (same version) is behaving differently on diffrent machines?

2. Is there any configuration/settings needed to have this issue fixed?

Please advise... 

Thank you all..


Re: IMPORT issue with Teradata SQL assistant.

Blank is not considered to be null instead a character. you need to specify NULL in the CSV file for Null characters.if the datatype is defined as a numeric NOT NULL  then it will be defaulted to zero. In the ODBC options while connecting please choose Teradata mode and AAA Datetime format and verify. Also in the general settings under tools> options please check what is the string to display for NULL data values.



Re: IMPORT issue with Teradata SQL assistant.

Thanks Krishna for reply, Settings under tools> options and "String to Display NULL data Value" is just to represent the character for NULLs its just for Result Sets / Output data representation, its nothing to do with the Loading NULL in table.

BTW in settings the NULL char is "?", so it should display  "?" for NULLs.

Table structure is absolutely fine, as i said i tried loading same table using same file on diffrent machine (with same SQL assistant version) and it is Loading NULLs and after loading am able to see NULL char i.e. "?" on both the machines.

Due to some reason IMPORT is working fine on one machine and not on another!!

I was wondering if theres any settings/configuration which is needed to avoid this...???

awaiting responces!

Thanks again.