Problem with XML for Data Mover Job

Tools & Utilities
Highlighted
New Member

Problem with XML for Data Mover Job

Hi,

After upgrade of data mover to v. 16.20 I have a problem with use_existing_target_table tag. It is deprecated in this version? I can't find information about it in release informations and it still exist in xml schema (http://schemas.teradata.com/unity/DataMover.xsd), but I find the example of xml in documentation -

"Sample Job Creation XML File
The following sample XML illustrates the correct order of all possible elements available for a job creation XML file"
and there is no use_existing_target_table tag.
 
I ask because I have the following error:
 

[org.xml.sax.SAXParseException; lineNumber: 58; columnNumber: 48; cvc-complex-type.2.4.a: Invalid content was found starting with element 'use_existing_target_table'. One of '{"http://schemas.teradata.com/dataMover/v2009":aster_table_params, "http://schemas.teradata.com/dataMover/v2009":validate_row_count, "http://schemas.teradata.com/dataMover/v2009":override_lock_access, "http://schemas.teradata.com/dataMover/v2009":export_without_spool, "http://schemas.teradata.com/dataMover/v2009":compare_ddl, "http://schemas.teradata.com/dataMover/v2009":map, "http://schemas.teradata.com/dataMover/v2009":colocate, "http://schemas.teradata.com/dataMover/v2009":journaling, "http://schemas.teradata.com/dataMover/v2009":sql_where_clause, "http://schemas.teradata.com/dataMover/v2009":key_columns, "http://schemas.teradata.com/dataMover/v2009":staging_to_target, "http://schemas.teradata.com/dataMover/v2009":table_columns}' is expected.]