Problems running TdGeoImportExport version 1.1

Tools & Utilities
Not applicable

Problems running TdGeoImportExport version 1.1

I am trying to use the TDGeoImport utility to load some data. I can not get it to run under either Vista or XP.

When using Vista I get and EXCEPTION_ACCESS_VIOLATION (0xc0000005) error from the JVM. Most suggestions regarding these errors suggest either the JVM or application have bugs or there is a security error. I have tried different directory permissions, different JVMs, disabling UAC - still no luck.

Vista Log

[font=Courier New]C:\Users\williamh\Documents\install\teradata\TdGeoImportExport\bin>"C:\Program Files\Java\jre6\bin\java" -classpath .;"C:\Users\williamh\Documents\ins

tall\teradata\TdGeoImportExport\bin\terajdbc4.jar";"C:\Users\williamh\Documents\install\teradata\TdGeoImportExport\bin\tdgssconfig.jar";. com.teradata

.geo.TDGeoImport -l,xxxxxx -s wsadmin -f C:\Users\williamh

Logon =,xxxxxx

DatabaseName = wsadmin

Data Source = C:\Users\williamh

connecting to ... connected!


importing layer Branch_mif to table BRANCH_MIF ...#

# A fatal error has been detected by the Java Runtime Environment:


# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x77d66739, pid=2628, tid=5644


# JRE version: 6.0_15-b03

# Java VM: Java HotSpot(TM) Client VM (14.1-b02 mixed mode, sharing windows-x86 )

# Problematic frame:

# C [ntdll.dll+0x66739]


# An error report file with more information is saved as:

# C:\Users\williamh\Documents\install\teradata\TdGeoImportExport\bin\hs_err_pid2628.log


# If you would like to submit a bug report, please visit:



Under XP I do not even get that far. I seem to have a PATH problem or be missing a DDL. Any ideas?

XP Log

[font=Courier New]C:\customer_data\xxxxxxxxxxx\TdGeoImportExport\bin>java -classpath .;terajdbc4.jar;tdgssconfig.jar;. com.teradata.geo.TDGeoImport -l

n,xxxxx -s wsadmin -f C:\Users\williamh

java.lang.UnsatisfiedLinkError: C:\customer_data\xxxxxxxx\TdGeoImportExport\bin\geojni.dll: This application has failed to start because the applica

tion configuration is incorrect. Reinstalling the application may fix this problem

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(Unknown Source)

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at com.teradata.geo.TDGeoImport.main(


Data importing failed![/font]