Reading UTF-16 Data File - MultiLoad (Windows)

Tools & Utilities
Not applicable

Reading UTF-16 Data File - MultiLoad (Windows)


I am using Teradata 13 on Windows... I am using the MLOAD client on Windows to load a data file which is in UTF16-LE format. All the columns are getting into the ERROR table. I tried running with the -c(character Set)  option with UTF16 and blank(ASCII) as well ,it doesn't help...

Using Teradata Studio (Data Loader) , I got a sample 100 records from the same file and was able to load successfully using the same specifications !!!! However I face the issue in using this to load the big file (6 GB) as the UI fails :(

Any idea on how to resolve this issue using the MLOAD batch script and what I may be missing...

I tried running MLOAD from Command Line using MLOAD -c UTF16 <XXX.mload > XXX.log




Tags (1)
Teradata Employee

Re: Reading UTF-16 Data File - MultiLoad (Windows)

When you specify -c UTF16, by default MLOAD assumes the input script is also UTF16. Try

mload -c UTF16 -i UTF8 <XXX.mload > XXX.log