SQL Assistant Copy Errors 14.10

Tools & Utilities

SQL Assistant Copy Errors 14.10

I have been having significant issues with simple windows functionality in SQL Assistant. Trying to copy text in the editor window throws the following error: 


4/10/2014 3:20:03 PM

SQLA Version:

Driver Version: Teradata.Net

System.Runtime.InteropServices.COMException (0x80004005): Unspecified error

   at CodeMax4.ICodeMax.Copy()

   at AxCodeMax4.AxCodeMax.Copy()

   at Teradata.SQLA.QueryFrm.Copy() in V:\cm.client.ttu141.efix\tdcli\qman\sqla\QueryFrm.vb:line 158

   at Teradata.SQLA.MainFrm.ToolbarMgr_ToolClick(Object sender, ToolClickEventArgs e) in V:\cm.client.ttu141.efix\tdcli\qman\sqla\MainFrm.vb:line 816


Same error with CTRL-C and the menu item selection. I've had the issue on Win7 and Win8 over the last several weeks. I was going to try to download TTU 13.10 but can't seem to find it on the site.  

Tags (1)
Teradata Employee

Re: SQL Assistant Copy Errors 14.10

Strange .... i am using the same version .... it works fine. Can you check if it gives you the same error via ODBC connection?

Teradata Employee

Re: SQL Assistant Copy Errors 14.10

This problem has been reported in the past. It seems that Microsoft changed something related to the clipboard such that attempts to access it through COM are failing.

In order to work around the problem I added code to manually handle Copy requests rather than allow the COM object to handle them itself.

This change was included in

This can be downloaded from the T@YS download center, as part of the TTU 14.10.06 [or higher] package.

The TTU software package available on this site is an older package that is intended only for use with the Developer 'Express' edition of Teradata Database. It is not generally updated with new patches.

(However I am told it will be updated with the TTU 14.10.12 package due at the end of this month, and that will contain SQL assistant